Subject: ParkBench BOF session at the SC'97

From: Erich Strohmaier <[email-masked]>
Date: Wed, 12 Nov 1997 21:31:00 -0500 (EST)

Dear Colleague,

  The ParkBench (PARallel Kernels and BENCHmarks) committee has
organized a BOF session at the SC'97 in San Jose.

   Room:   Convention Center Room C1 
   Time:   Wednesday  5:30pm              

We will talk about the latest release, new results available and future
plans.

                Tentative Agenda of the BOF

   - Introduction, background, WWW-Server 
   - Current Release of ParkBench
   - Low Level Performance Evaluation Tools
   - LinAlg Kernel Benchmarks
   - NAS Parallel Benchmarks,  including latest results
   - Plans for the next Release 
   - Electronic Journal of Performance Evaluation and Modeling
     for Computer Systems
   - Questions from the floor / discussion 

  Please mark your calendar and plan to attend.

Jack Dongarra
Tony Hey 
Erich Strohmaier

---

From: Mark Baker <[email-masked]>
Date: Thu, 13 Nov 97 10:48:53 GMT

Dear All,

Here are the minutes of the Parkbench committee meeting held The County
Hotel in Southampton during the Fall 97 Parkbench Workshop.

For those of you with a MIME-compliant mail-reader I've attached a formatted
word 7 doc.

Regards

Mark

-----------------------------------------------------------------------------

Parkbench Committee Meeting
Held during the Fall Parkbench Workshop

The County Hotel
Southampton, UK

1515,  11th September 1997

Meeting Participation List:

Mark Baker - Univ. of Portsmouth ([email-masked])
Flavio Bergamaschi  - Univ of Southampton ([email-masked])
Jack Dongarra - Univ. of Tenn./ORNL ([email-masked])
Vladimir Getov  - Univ. of Westminister ([email-masked])
Charles Grassl - SGI/Cray ([email-masked])
William Gropp - ANL ([email-masked])
Tony Hey - Univ. of Southampton ([email-masked])
Roger Hockney - Univ. of Westminister ([email-masked])
Mark Papiani - Univ of Southampton ([email-masked])
Subhash Saini - NASA Ames ([email-masked])
Dave Snelling - FECIT ([email-masked])
Aad J. van der Steen  - RUU ([email-masked])
Erich Strohmaier - Univ. of Tennessee ([email-masked])
Klaus Stueben - GMD  ([email-masked])

Meeting Activities and Actions

Tony Hey chaired the meeting.

Minutes from last meeting were seven pages long and it was decided that only the actions from the last 

meeting would be reviewed. The actions from last meeting were reviewed - a short discussion about each 

took place. A discussion about interaction with SPEC-HPG was initiated.

Comms Low-Level Benchmarks 

Vladimir Getov gave a short presentation on the current status of the Parkbench Comms benchmarks.  
Charles Grassl was asked to explained how his new Comms programs worked and the rationale behind it. 
A long discussion ensued.

Action - Create a formal proposal  of alternative or additions to the comms low-level benchmarks for 
SC'97 
- Charles Grassl.

Action - Members should look at the PALLAS version of the low-level benchmarks (based on 
Genesis/RAPS).

Action  - Erich  Strohmaier and Vladimir Getov will discuss the efforts needed to split up Parkbench 
and 
add in the new Comms1 benchmark (with new curve fitting routine).

NPB - Subhash Siani reported on the status of the NAS Parallel Benchmarks

HPF - Mark Baker read Chuck Koebel's email about CEWES HPCM HPF efforts.

Action - Subhash Siani will let RICE know that Gina should start of from the single NAS codes

Electronic Journal - Mark Baker and Tony Hey reported on the electronic journal PEMCS and its Web 
site. It was agreed that this would be discussed  further informally.

Parkbench Report -Erich Strohmaier reported on the efforts of creating a new Parkbench report. A short 

discussion about this ensued.

Action - Jack Dongarra /Tony Hey will talk to other members about the potential efforts that could be 
put 
into a Parkbench report II by SC'97.

Funding Efforts

Jack Dongarra's recent benchmarking  proposal was turned down. Tony Hey mentioned the possibly of 
entering a proposal to the EU.
Possibility of a joint EU / NSF bid.

Mark Baker asked if SIO would be interested in being more closely involved.  William Gropp reported 
that 
SIO was actually winding down and so formal association was not really an option.

AOB

The participants were then invited by Tony to move to the University of Southampton (bldg. 16) for the 

Parkbench demonstrations which included:

-- Java Low-Level Benchmarks (Vladimir Getov)
-- BenchView: Java Tool for Visualization of Parallel Benchmark Results (Mark Papiani and Flavio
   Bergamaschi)
-- PICT: An Interactive Web-page Curve-fitting Tool (Roger Hockney)

Jack Dongarra  informed the committee of  Parkbench BOF at SC'97 (Wednesday at 3.30PM).

The meeting was wound up by Tony Hey at 1630.

-----------------------------------------------------------------------------

-------------------------------------
CSM, University of Portsmouth, Hants, UK
Tel: +44 1705 844285	Fax: +44 1705 844006
E-mail: [email-masked]
Date: 11/13/97 - Time: 10:48:53
URL http://www.sis.port.ac.uk/~mab/
-------------------------------------

---

From: Mark Baker <[email-masked]>
Date: Thu, 13 Nov 97 10:48:53 GMT

Dear All,

Regards

Mark

The County Hotel
Southampton, UK

Funding Efforts

AOB