Subject: PBWG Draft Report

From: Prof Roger Hockney <[email-masked]>
Date: Wed, 24 Mar 93 12:34:10 GMT

A Message from Your Chairman
               ----------------------------

In view of the committee's aim to agree on a draft text at the meeting
on May 24, 1993, it would help if each subcommittee produces their
recommendations as LATEX files to fit into a standard framework.
I believe that LATEX is the most widely used text processing system in
the universities, and appears to have been used for the HPF report.
I have prepared the following skeleton files for the committee's report:

         (1) benrep1.tex  - control file for main report
         (2) bencom1.tex  - command definition file
         (3) benref1.bib  - start of bibliography

Additions to the command file and bibliography can be sent to me as files
bencom2.tex, benref2.bib etc.

The control file reads the following files which are to be provided
by the leader of each subcommittee:

         (4) intro1.tex  - Roger Hockney for whole committee
         (5) method1.tex - David Bailey for Methodology subcommittee
         (6) lowlev1.tex - Roger Hockney for the low-level subcommittee
         (7) kernel1.tex - Tony Hey for the kernel subcommittee
         (8) compac1.tex - David Walker for compact applications subcommittee
         (9) conclu1.tex - Roger Hockney for whole committee

Files (1), (2), (3), (5), (7), and (8) are appended to this e-mail.

          Best wishes, Roger Hockney.

% file : benrep1.tex
%
%        **************************************************************
%           STANDARD INTERNATIONAL BENCHMARKS FOR PARALLEL COMPUTERS
%        **************************************************************
%

\input{bencom1.tex}     % define new commands for benchmark report

% ----------------------------------------------------------------------------

\documentstyle[]{report}    % Specifies the document style.
\textheight 8.25 true in
\textwidth 5.625 true in
\topmargin -0.13 true in
\oddsidemargin 0.25 true in
\evensidemargin 0.25 true in

                           % The preamble begins here.

\title{Standard International Benchmarks for Parallel Computers}

% ----------------------------------------------------------------------------

\author{PBWG Committee \\
        draft assembled by Roger Hockney (chairman)}
\date{23 March 1993 - draft 1}

% ----------------------------------------------------------------------------

\begin{document}           % End of preamble and beginning of text.
\sloppy
\maketitle                 % Produces the title.

% ----------------------------------------------------------------------------

\input{intro1.tex}  % Introduction
% responsibility of Roger Hockney for whole committee

% ----------------------------------------------------------------------------

\input{method1.tex}  % Chapter1 
% responsibility of David Bailey for Methodology subcommittee 

% ----------------------------------------------------------------------------

\input{lowlev1.tex}  % Chapter2
% responsibility of Roger Hockney for Low-level benchmarks subcommittee

% ----------------------------------------------------------------------------

\input{kernel1.tex}  % Chapter3
% responsibility of Tony Hey for Kernel benchmarks subcommittee

% ----------------------------------------------------------------------------

\input{compac1.tex}  % Chapter4
% responsibility of David Walker for Compact Applications subcommittee

% ----------------------------------------------------------------------------

\input{conclu1.tex}  % Conclusions
% responsibility of Roger Hockney for whole committee

% ----------------------------------------------------------------------------

\vspace{0.35in}
{\large \bf Acknowledgments}

\bibliography{benref1}
\bibliographystyle{unsrt}

\end{document}             % End of document.

% file : bencom1.tex
%
%        **************************************************************
%                      LATEX COMMANDS FOR PARABEN REPORTS
%        **************************************************************
%

\def\flop{\mathop{\rm flop}\nolimits}
\def\pipe{\mathop{\rm pipe}\nolimits}
\newcommand{\usec}{\mbox{\rm $\mu$s}}
\newcommand{\where}{\mbox{\rm where}}
\newcommand{\rmand}{\mbox{\rm and}}
\newcommand{\Mflops}{\mbox{\rm Mflop/s}}
\newcommand{\flops}{\mbox{\rm flop/s}}
\newcommand{\flopB}{\mbox{\rm flop/B}}
\newcommand{\tstepps}{\mbox{\rm tstep/s}}
\newcommand{\MWps}{\mbox{\rm MW/s}}
\newcommand{\Mwps}{\mbox{\rm Mw/s}}
\newcommand{\spone}{\mbox{\ }}
\newcommand{\sptwo}{\mbox{\ \ }}
\newcommand{\spfour}{\mbox{\ \ \ \ }}
\newcommand{\spsix}{\mbox{\ \ \ \ \ \ }}
\newcommand{\speight}{\mbox{\ \ \ \ \ \ \ \ }}
\newcommand{\spten}{\mbox{\ \ \ \ \ \ \ \ \ \ }}
\newcommand{\rinf}{\mbox{$r_\infty$}}
\newcommand{\Rinf}{\mbox{$R_\infty$}}
\newcommand{\nhalf}{\mbox{$n_{\frac{1}{2}}$}}
\newcommand{\Nhalf}{\mbox{$N_{\frac{1}{2}}$}}
\newcommand{\phalf}{\mbox{$p_{\frac{1}{2}}$}}
\newcommand{\Phalf}{\mbox{$P_{\frac{1}{2}}$}}
\newcommand{\half}{\mbox{$\frac{1}{2}$}}
\newcommand{\rnhalf}{\mbox{(\rinf,\nhalf)}}
\newcommand{\RNhalf}{\mbox{(\Rinf,\Nhalf)}}
\newcommand{\third}{\mbox{$\frac{1}{3}$}}
\newcommand{\quart}{\mbox{$\frac{1}{4}$}}
\newcommand{\eighth}{\mbox{$\frac{1}{8}$}}
\newcommand{\nineth}{\mbox{$\frac{1}{9}$}}

% ----------------------------------------------------------------------------

% file : benref1.bib
%
@book{HoJe88, 
   author= "Roger W. Hockney and Christopher R. Jesshope", 
   title=  "Parallel Computers 2:
   Architecture, Programming and Algorithms",
   publisher= "Adam Hilger/IOP Publishing", 
   address= "Bristol \& New York", 
   year= "1988",
   note= "Distributed in the USA by the American Institute of Physics,
   c/o AIDC, 64 Depot Road, Colchester, VT 05445."}

@book{Super,
   key="Super",
   title={Supercomputer},
   publisher="ASFRA",
   address="Edam, Netherlands"}

@book{SI75,
   key="Royal Society",
   organization="Symbols Committee of the Royal Society",
   title={Quantities, Units and Symbols},
   publisher="The Royal Society", 
   address="London", 
   year=1975}

@article{Berr89, 
   author="M. Berry and D. Chen and P. Koss and D. Kuck and S. Lo and Y. Pang 
   and L. Pointer and R. Roloff and A. Sameh and E. Clementi and S. Chin
   and D. Schneider and G. Fox and P. Messina and D. Walker and C. Hsiung
   and J. Schwarzmeier and K. Lue and S. Orszag and F. Seidl and
   O. Johnson and R. Goodrum and J. Martin",
   title="The {PERFECT} Club benchmarks: effective performance evaluation of
   computers",
   journal={Intl. J. Supercomputer Appls.}, 
   volume=3,
   number=3, 
   year=1989, 
   pages="5-40"}

@incollection{Ma88,
   author="F. H. McMahon",
   title="The {L}ivermore {F}ortran Kernels test of the numerical 
            performance range",
   editor="J. L. Martin", 
   booktitle={Performance Evaluation of Supercomputers},
   publisher="Elsevier Science B.V., North-Holland", 
   address="Amsterdam", 
   year=1988, 
   pages="143-186"}

@article{Mess90,
   author="P. Messina and C. Baillie and E. Felten and P. Hipes and 
   R. Williams and A. Alagar and A. Kamrath and R. Leary and W. Pfeiffer
   and J. Rogers and D. Walker",
   title="Benchmarking advanced architecture computers",
   journal={Concurrency: Practice and Experience},
   volume=2,
   number=3, 
   year=1990, 
   pages="195-255"}

@inproceedings{Cvet90,
   author="Z. Cvetanovic and E. G. Freedman and C. Nofsinger",
   title="Efficient decomposition and performance of parallel {PDE}, 
   {FFT}, {M}onte-{C}arlo simulations, simplex and sparse solvers",
   booktitle={Proceedings Supercomputing90}, 
   publisher="IEEE", 
   address="New York", 
   year=1990, 
   pages="465-474"}

@article{SUPR88,
  title="Proceedings 2nd International SUPRENUM Colloquium",
  author="U. Trottenberg",
  journal={Parallel Computing},
  volume=7, 
  number=3,
  year=1988}

@article{Hey91, 
   author="A. J. G. Hey",
   title="The {G}enesis Distributed-Memory Benchmarks",
   journal={Parallel Computing}, 
   volume=17,
   year=1991,
   pages="1275-1283"}

@book{F90,
   author="M. Metcalf and J. Reid",
   title={Fortran-90 Explained}, 
   publisher="Oxford Science Publications/OUP",
   address="Oxford and New York", 
   year=1990, 
   chapter=6}

@article{SPEC90,
   key="SPEC", 
   title="{SPEC} Benchmarks Suite Release 1.0",
   journal={SPEC Newslett.}, 
   volume=2,
   number=3,
   year=1990,
   pages="3-4",
   publisher="Systems Performance Evaluation Cooperative, Waterside Associates",
   address="Fremont, California"}

@article{FGHS89, 
   author="A. Friedli and W. Gentzsch and R. Hockney and A. van der Steen",
   title="A {E}uropean Supercomputer Benchmark Effort", 
   journal={Supercomputer 34}, 
   volume="VI",
   number=6,
   year=1989,
   pages="14-17"}

@article{BRH90,
   author="L. Bomans and D. Roose and R. Hempel",
   title="The {A}rgonne/{GMD} Macros in {F}ortran for portable parallel 
   programming and their implementation on the {I}ntel i{PSC}/2",
   journal={Parallel Computing},
   volume=15,
   year=1990,
   pages="119-132"}

@inproceedings{ShTu91,
   author="J. N. Shahid and R. S. Tuminaro",
   title="Iterative Methods for Nonsymmetric Systems on {MIMD} Machines",
   booktitle={Proc. Fifth SIAM Conf. Parallel Processing for Scientific
   Computing},
   year=1991}

@article{Bish90,
   author="N. T. Bishop and C. J. S. Clarke and R. A. d'Inverno",
   journal={Classical and Quantum Gravity},
   volume=7,
   year=1990, 
   pages="L23-L27"}

@article{Isaac83,
   author="R. A. Isaacson and J. S. Welling and J.Winicour",
   journal={J. Math. Phys.},
   volume=24,
   year=1983,
   pages="1824-1834"}

@article{Stew82,
   author="J. M. Stewart and H. Friedrich",
   journal={Proc. Roy. Soc.},
   volume="A384",
   year=1982, 
   pages="427-454"}

@article{Hoc92, 
   author="R. W. Hockney",
   title="A framework for benchmark analysis",
   journal={Supercomputer}, 
   volume=48,
   number="IX-2", 
   year=1992, 
   pages="9-22"}

@article{Add93, 
   author="C. Addison and J. Allwright and N. Binsted and N. Bishop and 
   B. Carpenter and P. Dalloz and D. Gee and V. Getov and A. Hey and
   R. Hockney and M. Lemke and J. Merlin and M. Pinches and C. Scott and
   I. Wolton",
   title="The {G}enesis distributed-memory benchmarks. Part 1: methodology
   and general relativity benchmark with results for the {SUPRENUM}
   computer",
   journal={Concurrency: Practice and Experience}, 
   volume=5,
   number=1, 
   year=1993, 
   pages="1-22"}
%
% -------------------------------------------------------------------------

%file: intro1.tex
\chapter{Introduction}\footnotemark
\footnotetext{written by Roger Hockney for whole committee} 
\cite{HoJe88}

%
% -------------------------------------------------------------------------

%file: method1.tex
\chapter{Methodology}
\footnote{assembled by David Bailey for Methodology subcommittee}

%
% -------------------------------------------------------------------------

%file: lowlev1.tex
\chapter{Low-Level Benchmarks}
\footnote{assembled by Roger Hockney for low-level subcommittee}

%
% -------------------------------------------------------------------------

%file: kernel1.tex
\chapter{Kernel Benchmarks}
\footnote{assembled by Tony Hey for Kernel subcommittee}

%
% -------------------------------------------------------------------------

%file: compac1.tex
\chapter{Compact Applications}
\footnote{assembled by David Walker for Compact Applications subcommittee}

%
% -------------------------------------------------------------------------

%file: conclu1.tex
\chapter{Conclusions}
\footnote{written by Roger Hockney for whole committee}

%
% -------------------------------------------------------------------------
% End of skeleton paper

---

From: [email-masked]
Date: Mon, 29 Mar 93 12:51:54 -0500

I thought we agreed to add additional section to the draft on
compiler benchmark. Syracuse volunteers to coordinate that effort,
and  to provide the text for the draft.

Will you add this section to the draft, please?

Tom Haupt