Subject: mpi_statusall

From: David W. Walker <[email-masked]>
Date: Tue, 15 Jun 93 10:54:02 -0500

The current version of the draft does not have an mpi_statusall routine, i.e., a routine
that returns a flag as true if all the communication operations in a list are complete,
and returns it as false otherwise.

Was such a routine ever discussed? Are there compelling reasons for including or
excluding it?

David

---

From: James Cownie <[email-masked]>
Date: Tue, 15 Jun 1993 16:13:31 +0100

> Was such a routine ever discussed? 
Not that I can remember.

> Are there compelling reasons for including or excluding it?
Reasons which spring to mind (I'll let you judge their compulsion
level) 

For :
	symettry with mpi_wait, mpi_waitall
	implementation efficiency. (One call instead of many).

Against:
	you can do it yourself with a loop.

-- Jim
James Cownie 
Meiko Limited			Meiko Inc.
650 Aztec West			Reservoir Place
Bristol BS12 4SD		1601 Trapelo Road
England				Waltham
				MA 02154

Phone : +44 454 616171		+1 617 890 7676
FAX   : +44 454 618188		+1 617 890 5042
E-Mail: [email-masked]   or    [email-masked]